Mazda MX5 Forum banner
1 - 15 of 15 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter · #1 ·
Hi
Just bought a mx5 mk1 1990. It runs at mid temp around town but as soon as I get above 65 mph the temp gauge goes up to hot.if I slow down to 55 it starts to go back to mid temp within a minute or two.has anyone else had this as don't want to go changing loads of parts as a process of elimination
 

·
Away with the fairies
Joined
·
41,321 Posts
Hi Mark, welcome to MX5life :)

Sorry i cant help with your problem

but i'm sure someone will be along that can :)

think a lot have gone on runs today

so it may be this evening :)
 

·
Premium Member
Joined
·
218 Posts
Hi Mark,

Welcome to 5life.com :)

I'd agree with 'badman', it sounds like a lack of coolant, at higher engine revs.

This could be as above or a blockage, restricting coolant flow around the engine.

It may be worth flushing the cooling system through, until it runs clear.

May even be worth checking thermostat operation too...

Hope you get it sorted soon.
 

·
Premium Member
Joined
·
3,651 Posts
Water pump!

I'll agree with all that has already been said.

Take the bottom hose off and blast through with a hose as hard as possible until it runs clear.

Refill with anti freeze, it's not just antifreeze it's a corrosion inhibitor and a summer coolant.

If you can, get an air line and blow through the radiator matrix, not forgetting you've 20 odd years of dead bees and wasp built up there.

I wouldn't have thought it would be the thermostat as they tend to fail i.e. stick open or closed, although it could be partialy blocked.

Gut feeling is the water pump, water pumps are belt drive vanes and the vanes don't last forever, especially if antifreeze hasn't been topped up or changed.

Dave.
 

·
Premium Member
Joined
·
3,651 Posts
I've just striped a water pump out of a flat six 4ltr engine, what a mess, I'll post pic later when i get home.
 

·
Premium Member
Joined
·
3,651 Posts
This is how a waterpump shouldn't be, 2 years old.

Cause, lack of antifreeze.

I've got the new pump on order, for those of you who don't know what it should look like i'll post a pic when i get it.
 

Attachments

·
Premium Member
Joined
·
28,307 Posts
Only good for scrap that. .

Wouldn't think adding antifreeze would stop
that happening. And my boss doesn't bother bout
things like that.
 
1 - 15 of 15 Posts
Top